KCS - Cannot See Emails Being Sent to A Matter

Issue:

  • I'm forwarding an email to Clio, but it's not showing up anywhere.
  • My Clients' e-mails aren't appearing in the Matter or Contact Communications.
  • Emails forwarded via Maildrop are not being added to the Matter.

Environment:

  • Clio Web App

Additional Information:

Clio blocks all received Maildrop emails from unfamiliar email addresses to prevent unauthorized 3rd parties from maliciously creating data in our users' accounts. 

Cause:

Clio will block all received Maildrop emails unless either:

  1. The email address it was sent from matches the email address of a user on that Clio account
  2. The email address it was sent from matches an email alias of a user on that Clio account

Resolution:

Either:

  1. Add your email address as a Maildrop Alias (see here).
  2. Create a new user in the Clio account that uses that email address
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