Issue:
- Quickbooks Error Code (2500): Invalid Reference Id. Something you're trying to use has been deleted. Check the fields with accounts, customers, items, vendors or employees.
Environment:
- Clio Web App
- Bill Syncing
- Quickbooks Online
Additional Information:
Cause:
-The item referenced was deleted in QBO or Clio.
-The Contact may have originally been duplicated in Clio. Then the incorrect Contact was deleted in QuickBooks Online, leaving no Contact for Clio to sync future updates/items, which would produce this 2500 error.
Resolution:
By changing the name of the remaining QBO Contact to something unique, clicking Re-sync on the QBO error for the Contact itself, and then in QBO merging the previously existing contact into the newly created one.
This is only one example of solving this issue, and other situations may exist. If further assistance is needed you can call our Support Line at 1-888-858-2546