KCS - Delete Option Not Available for Transaction

Issue:

  • Cannot Edit or Delete Transaction in New Clio
  • Editing Bill Payments button unavailable

Environment:

  • Clio Web App

Additional Information:

As Contacts were not updated in New Clio, the same functionality is available for Transactions at the Contact level.

Cause:

The Delete button has not been added for certain Transactions in the New Clio Experience although it will be added in the future.

Resolution:

  1. Access the page for the relevant Contact
  2. Select the Transactions tab
  3. Edit or Delete the Transaction
Was this article helpful?
This information is confusing or wrong
This isn't the information that I was looking for
I don't like this functionality