KCS - Which Versions of Mac OS Are Supported by Clio?

Objective:

  • Determine which versions of Mac OS support the modern Browsers needed to run Clio.

Environment:

  • Clio Web App
  • Google Chrome
  • Mozilla Firefox
  • Safari
  • Opera

Additional Information:

You should always have the most up-to-date version of your web browser in order for Clio to run smoothly. 

For supported versions of Windows, click here.

Answer:

Google Chrome

  • Macbook Pro 2010, Macbook Air 2011
  • OS X 10.9 "Mavericks" or above

Mozilla Firefox

  • Macintosh computer with an Intel x86 processor
  • OS X 10.9 "Mavericks" or above

Opera

  • OS X 10.10 "Yosemite" or later

Safari

  • OS X 10.7.4 "Lion" or later
Was this article helpful?
This information is confusing or wrong
This isn't the information that I was looking for
I don't like this functionality