Have you heard? We acquired Lexicata in the first milestone to creating a more advanced client engagement platform. Read more here.

KCS - Which Versions of Windows Are Supported by Clio?

Objective:

  • Determine which versions of Windows support the modern Browsers needed to run Clio.

Environment:

  • Clio Web App
  • Google Chrome
  • Mozilla Firefox
  • Microsoft Internet Explorer
  • Microsoft Edge

Additional Information:

You should always have the most up-to-date version of your web browser in order for Clio to run smoothly. 

Microsoft officially stopped supporting Windows XP on April 8th, 2014. This means that Microsoft will no longer provide security updates or technical support for the Windows XP operating system. It is very important that customers and partners migrate to a modern operating system such as Windows 10.

For supported versions of Mac OS, click here.

Answer:

Google Chrome:

  • Core i3 or equivalent
  • Windows 7, Windows 8, Windows 10 or later

Mozilla Firefox:

  • Pentium 4 or newer with SSE2 (encompasses most machines since 2001)
  • Windows 7, Windows 8, Windows 10 or later

Microsoft Internet Explorer

  • Pentium 4 or newer with SSE2 (encompasses most machines since 2001)
  • Windows 7, Windows 8 (pre-installed)

Microsoft Edge

  • Pentium 4 or newer with SSE2 (encompasses most machines since 2001)
  • Windows 10 or later (pre-installed)
Was this article helpful?
This information is confusing or wrong
This isn't the information that I was looking for
I don't like this functionality