KCS - I Can't Find a Trust Request I Just Created

Issue:

  • Unable to locate a Trust Request recently created for a customer 

Environment:

  • Clio Web App

Additional Information:

n/a

Cause:

The Trust Request is associated to the Client, but the user is looking at the Matter level 

Resolution:

  1. Open the Contact Card or Client page 
  2. Select Bills 

 

Was this article helpful?
This information is confusing or wrong
This isn't the information that I was looking for
I don't like this functionality