KCS - What Versions of Outlook does the Outlook Add-in Work With?

Objective:

  • What are the requirements for using the Outlook Add-in?

Environment:

  • Outlook Add-in

Additional Information:

The Clio Add-in is only available to Outlook Desktop 2013 or higher with an Office 365 subscription.

The Clio Add-in only works with Microsoft-backed email accounts. Though you can view email accounts from other providers in Outlook, you cannot use the Add-in with these emails.

Answer:

The Clio Add-in for Outlook supports both Outlook desktop 2013+ (with an Office 365 subscription) and Outlook.com.

 

Was this article helpful?