Issue:
- Why do my contacts get Duplicated every time I send a bill via email or Clio Connect?
Environment:
- Clio Manage
Additional Information:
n/a
Cause:
You may be clicking + Add a Contact button when sending the bill instead of filling out the Select Contacts field. Doing this will create a new Contact to share with, instead of sending to an Existing Contact.
Resolution:
Use the Select Contacts field to choose Contacts you want to share with.