KCS - Credit Note Isn't Saving on a Bill

Issue:

  • Added a Credit Note and it won't apply to the Bill

Environment:

  • Clio Web App

Additional Information:

n/a

Cause:

The description may be too long.

Resolution:

  1. Try saving the credit note with a shorter description

 

Was this article helpful?
This information is confusing or wrong
This isn't the information that I was looking for
I don't like this functionality