KCS - All of My Contacts are Gone

Issue:

  • Contacts were inadvertently deleted through a third party sync 
  • Clients are missing

Environment:

  • Clio Web App

Additional Information:

  • Only Administrator Users can access the Recovery Bin
  • You can review additional details about the deletions by accessing the Firm Feed from the Dashboard tab

Cause:

A member of your firm is syncing Contacts with Google or Outlook and has deleted Contacts from Google/Outlook (or through another application that is also syncing bidirectionally with Google/Outlook)

Resolution:

  1. Go to Settings
  2. Select Recovery Bin
  3. Click on Filter
  4. For Type, select Contact
  5. Check the Select All box, at the top of the page (or check off the Contacts that you wish to restore individually)
  6. For Action, select Recover
  7. Click Apply

 

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