Why am I seeing an error message when trying to update my credit card on my subscription?

Issue:

  • Receiving error message on updating credit card details
  • Payment error "Cannot Be Process"
  • An extension has been applied previously  

Environment:

  • Clio Web App

Additional Information:

Cause:

This is an expected message when an extension has been applied to the account in the past. Your card will automatically be processed on the next Billing Cycle Date.

 

Was this article helpful?
This information is confusing or wrong
This isn't the information that I was looking for
I don't like this functionality