Issue:
- I'm forwarding an email to Clio, but it's not showing up anywhere
- My Clients' e-mails aren't appearing in the Matter or Contact Communications
- Emails forwarded via Maildrop are not being added to the Matter
- Maildrop doesn't work
- Maildrop isn't working
Environment:
- Clio Manage
Additional Information:
Clio blocks all received Maildrop emails from unfamiliar email addresses to prevent unauthorized 3rd parties from maliciously creating data in our users' accounts.
Email Aliases are User specific, not firm-wide.
Once you have added the Email Alias to your account in Clio, this will only affect emails going forward. Previous emails will need to be re-sent.
Cause:
Clio will block all received Maildrop emails unless either:
- The email address it was sent from matches the email address of a user on that Clio account
- The email address it was sent from matches an email alias of a user on that Clio account
Resolution:
- Add your email address as a Maildrop Alias (for the steps to do so, click here)