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Why Can't I log in to Clio?

Issue:

  • I cannot log in to Clio Manage
  • User login does not work
  • User Unable to Access Account 
  • Not able to access Clio account
  • Trouble accessing Clio
  • Can't log in to their account
  • Error message "Couldn't log you in with that email/password combo. If you're stuck, you can reset your password."
  • Error message "The page you were looking for doesn't exist."
  • Why is Dashboard not loading? 
  • Why is Clio making me reset my password?
  • Cannot log into Clio

Environment:

  • Clio Manage

Additional Information:

If the following message is displayed:

Screen_Shot_2019-04-18_at_7.38.45_AM.png

Please see:

Cause:

Listed below are multiple steps that are likely causing this issue.

Resolution(s):

  1. Ensure the correct email address is being used:
  2. Ensure correct URL is being accessed (US: app.clio.com EU: eu.app.clio.com
  3. Ensure that the web browser is not remembering old login information
  4. Confirm with your account Administrator (or the firm, if you're a client) that you are properly enabled
  5. If you are the Account Owner, consider whether the Account may have become suspended as a result of an error with your payment
  6. If the password has expired, it can be reset at:
  7. Following a password reset, attempt logging in with an alternate browser
  8. Wait 10 minutes and attempt to log in again (Clio will throttle logins after 10 failed attempts)
  9. Ensure that your Firewall and or Proxy Server is not blocking our URL (This can be checked on your router)
  10. If you are still encountering issues, please contact our Support Team HERE

 

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