Issue:
- The credit card hasn't been processed after 48 hours
Environment:
- Clio Manage
Additional Information:
n/a
Cause:
- Sometimes a Payment does not get processed due to insufficient funds but there is no way of us knowing that unless we reach out to LawPay.
Resolution:
- Contact LawPay Support at 800.459.5798, they are able to provide you with more information about if the transaction went through or not.