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Quickbooks Error Code: (6140)

Issue:

  • Quickbooks Error Code (6140): Duplicate Document Number Error 

Environment:

  • Clio Manage
  • Quickbooks

Additional Information: 

  • For a full list of Quickbooks Error Codes click here.
  • To find Quickbooks errors click here.

Cause:

This error indicates that either a Bill, a Bill Payment, an Interest charge, Credit Memo, or maybe something else has not been synced because the QBO Document Number that Clio is trying to use has already been used by Quickbooks. There are cases where a duplicate number may not appear to exist in Quickbooks, but the invoice number is still not accepted by Quickbooks. 

Not all errors of this type are strictly for bills/invoices. For example, Credit Memos created manually in Quickbooks Online will will create a special "Credit Memo" invoice which have a "Credit Memo no." automatically assigned. This "Credit Memo no." behaves exactly like an invoice number and can conflict with Bill numbers created in Clio.

The error shown in Clio will give you clues as to what record in Quickbooks is conflicting with Clio.

For example with the error:

Code (6140): Duplicate Document Number Error : You must specify a different number. This number has already been used. DocNumber=1234 is assigned to TxnType=Credit Memo with TxnId=111

DocNumber is the document number being used by Clio that already exists in Quickbooks and causing the error. This is most often the Bill number in Clio conflicting with an invoice in Quickbooks. The Document number could be different than the actual bill in Clio if you charge interest, so pay close attention. If you cannot find an invoice with this number in Quickbooks, try a Global Search of the DocNumber.

TxnType is the type of record or transaction in Quickbooks that has the duplicate Document Number Clio is trying to use.

TxnId is an ID used by Quickbooks to identify the record and can be found in the URL of the record in Quickbooks.

All of this information can be used to pull up the offending record in Quickbooks. In the example above, the Credit Memo with the TxnId 111 can be found at:

https://app.qbo.intuit.com/app/creditmemo?txnId=111

An invoice with with the TxnID 123 can be found at:

https://app.qbo.intuit.com/app/invoice?txnId=123

For different TxnTypes, open a transaction of the same type in Quickbooks and change the txnId in the URL.

 

Resolution:

  1. Select Settings
  2. Select Bill Syncing 
  3. Locate the Error Code by scrolling down 
  4. Select Retry

If the above steps don't correct the issue. Modify the invoice number either in Clio or in QBO first, and then complete the steps listed above. It may be best to make the modification to the Invoice in QBO that is causing the issue as this is not a Customer Facing Invoice.

To edit the invoice number in Clio, complete the following steps: 

  1. Open the Invoice 
  2. If there are any payments, select Edit or Delete beside a payment 
    • You will not be able to edit a paid bill until payments are deleted first.
    • Please make a note of these payment details before deleting or editing it so that they can be reapplied once the invoice number has been changed.
  3. Click More options
  4. Select Edit (Click here for directions to allow editing on approved bills if needed)
  5. Update the invoice number by retyping a higher number (or unique number) in the ID# field 
  6. Select Save invoice 
To change an invoice number in QBO follow the steps below:
  1. Go to Sales or Invoicing, then click on the Invoices tab.
  2. Select the invoice in question.
  3. Go to the Invoice no. field and change the invoice number.
  4. Click Save and Close or Save and Send
  5. Click the Retry button in Clio as instructed above

To change the Credit Memo No in QBO follow the steps below:

  1. Search for the document number in the Global Search
  2. Select the Credit Memo from the search results
  3. Change the number in the Credit Memo no. field
  4. Click Save and Close or Save and Send
  5. Click the Retry button in Clio as instructed above

Finally, if the above steps still do not resolve the issue, try deleting the invoice and re-generating. 

 

 

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