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QuickBooks Online Error Code: (6140)

Issue:

  • QuickBooks Online Error Code (6140): Duplicate Document Number Error 

Environment:

  • Clio Manage
  • QuickBooks Online

Additional Information: 

  • For a full list of QuickBooks Online Error Codes click here.
  • To find QuickBooks Online errors click here.

Cause:

This error occurs when Clio attempts to sync something to QuickBooks Online, but that number has already been used elsewhere in Quickbooks Online. This could be a bill, bill payment, interest charge, credit note, journal entry or something else. There are cases where a duplicate number may not appear to exist in QuickBooks Online, but the invoice number is still not accepted by QuickBooks Online. 

Numbers in Quickbooks must be unique for the transaction type. For instance, a Bill in Clio may not sync to QuickBooks Online because a credit memo in QuickBooks Online already uses the same number.

The error shown in Clio will give you clues as to what record in QuickBooks Online is conflicting with Clio. For example:

Code (6140): Duplicate Document Number Error : You must specify a different number. This number has already been used. DocNumber=1234 is assigned to TxnType=Credit Memo with TxnId=111

  • DocNumber is the document number being used by Clio that already exists in Quickbooks and causing the error. 
  • TxnType is the type of record or transaction in Quickbooks that has the duplicate Document Number Clio is trying to use.
  • TxnId is an ID used by Quickbooks to identify the record and can be found in the URL of the record in Quickbooks.

This can be used to pull up the offending record in QuickBooks Online. In the example above:

  • The Credit Memo with the TxnId 111 can be found at: https://app.qbo.intuit.com/app/creditmemo?txnId=111
  • An invoice with with the TxnID 123 can be found at: https://app.qbo.intuit.com/app/invoice?txnId=123

For different TxnTypes, open a transaction of the same type in QuickBooks Online and change the txnId in the URL.

 

Resolution:

Retry the sync in Clio once issue is resolved in Quickbooks Online:

  1. Select Settings
  2. Select Bill Syncing 
  3. Locate the Error Code by scrolling down 
  4. Select Retry

Bills

If bills in Clio are causing the 6140 error, either:

  1. Add a Bill Prefix in QuickBooks Online Sync Settings (see here) and retry the sync (see above)
  2. Edit the bill's number in Clio (see here) and retry the sync (see above)
    • Note: If this error is being caused by an interest charge in Clio, this option is not available. Options 1 or 3 would need to be used.
  3. Edit the invoices number in QuickBooks Online (see here) and retry the sync in Clio (see above)

Additional Information:
If the Bill is in the Paid status (see here) on editing Paid Bills. 

 

Credit Memos

To change the Credit Memo No in QuickBooks Online follow the steps below:

  1. Search for the document number in the Global Search
  2. Select the Credit Memo from the search results
  3. Change the number in the Credit Memo no. field
  4. Click Save and Close or Save and Send
  5. Click the Retry button in Clio (see above)

 

Trust Transactions

See here. 

 

 

 

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