KCS - "Bad Request" Error When Setting up the Clio and OneDrive Integration

Issue:

  • Error: "Sorry, but we're having trouble signing you in. We received a bad request"
  • Error: "AADSTS50020: User account 'email' from identity provider 'live.com' does not exist in tenant 'Themis Solutions Inc.' and cannot access the application 'f8f54c30-b93a-428f-8d08-17c500229785' in that tenant. The account needs to be added as an external user in the tenant first. Sign out and sign in again with a different Azure Active Directory user account."
  • Unable to integrate with Microsoft OneDrive account

Environment:

  • Microsoft Office 365
  • Clio Web App

Additional Information:

Clio is only compatible with Microsoft Office 365 Business, Business Premium, and Enterprise Plans. 

Another potential cause is bad cached data/cookies—try linked to Office 365 in the private browsing mode (e.g. Incognito) and if it works, clear your browser's cache.

Cause:

Non-business plans, including Microsoft Office 365 Home are incompatible with Clio's Integrations. This error displays when users attempt to sign-in using incompatible Microsoft accounts.

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