The 2020 Legal Trends Report is now available. Get the latest insights here.

Error Sending Invitation to a New User: Email Has Already Been Taken

Issue:

  • Unable to add a user 
  • Can't add a new firm member 
  • Keep receiving error message 

Environment:

  • Clio Manage

Additional Information:

  • If the other email is associated with a paid Clio account that is in a canceled state, contact Support. 
  • Another reason this might happen is if the email address has been previously used by another user who is currently deactivated. If this is the case, see here.

Cause:

  • The email address is already in use by another paid Clio account. Each email address can only be associated with one paid account.

Resolution:

  • The user will need to update the existing email from the other account in order to use the email already in use or they can create a different email for the current account.
  • For further assistance with this issue, you may contact Clio Support via our in-app chat or by calling 1-888-858-2646 ext 2 (toll-free) 

 

Was this article helpful?
This information is confusing or wrong
This isn't the information that I was looking for
I don't like this functionality