Issue:
- Unable to reset the password for Clio Connect
Environment:
- Clio Manage
- Clio Connect
Additional Information:
n/a
Cause:
When you sign up for a trial account using the same email address as your Clio Connect account, you are unable to change the password associated with the Clio Connect account until the trial account has been confirmed
Resolution:
- Locate the Clio confirmation email that was sent to the email address in question
- If you cannot find the confirmation email, please reach out to Customer Support at 1-888-858-2546
- Confirm the creation of the trial account and set the password at this time which will be used for both the trial and Clio Connect account