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Why are There Duplicate Contacts/Matters in the Pipeline?

Issue:

  • Duplicate contacts/matters showing in the pipeline after clients set up appointments

Environment:

  • Clio Grow

Cause:

If the appointment type is set to Add new appointments directly to pipeline it means that a new contact record will be created when an appointment is booked. If that contact already exists, it will result in a duplicate contact being created. For non-paid appointment types, you can adjust this setting so that when appointments are booked, they are added to your lead inbox where you can review and check if there is an existing contact record before proceeding. Note that this setting cannot be changed for paid appointment types as a contact and matter needs to be created at the time the appointment is booked in order to record the payment.

Resolution:

For non-paid appointment types, adjust your appointment type setting so that new appointments are added to your lead inbox where you can either create a new contact or assign it to an existing contact:

  1. Click Settings
  2. Click Appointment Types
  3. Click the 3 dots (...) on the right side of the appointment name
  4. Click Edit
  5. Click What appointment is this?
  6. Under On appointment booking, click Add new appointments to lead inbox to allow for a confirmation 
  7. Click Save and Close

 

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