The 2020 Legal Trends Report is now available. Get the latest insights here.

"There was an error processing your card, please try again or reach out to our Support Team" Error When Paying for My Clio Subscription

Issue:

  • This error shows up when trying to pay for our firm Clio subscription: "There was an error processing your card, please try again or reach out to our Support Team"

Environment:

  • Clio Manage

Additional Information:

  • n/a

Cause:

Your bank may have declined the charge. 

Resolution:

  1. Check with your bank if they blocked the transaction
  2. If not, please contact Support

 

Was this article helpful?
This information is confusing or wrong
This isn't the information that I was looking for
I don't like this functionality