Issue:
- Clients have signed documents in Grow, but I cannot view them and the Status is still showing as Pending on the matter page in Grow
Environment:
- Clio Grow
Additional Information:
- n/a
Cause:
There are multiple documents with the same name sent to the client.
Resolution:
Please remove documents with duplicate names from the matter's Workflow tab.
- Click Options under the Pending status
- Click Delete Document
- Click Delete Document button