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"Oops! Something went wrong. Apologies something unexpected happened, and we couldn't sign you up for a new account." Error When Signing Up for a Clio Account

Issue :

  • When signing up for a new Clio account, I see an error that says "Oops! Something went wrong. Apologies something unexpected happened, and we couldn't sign you up for a new account. Please contact sales@clio.com and a representative will be in touch."

Environment:

  • clio.com
  • clio.com/uk/signup

Additional Information:

  • n/a

Cause:

The email you used to sign up was previously used to sign up for a different account (likely under a different country's server) - ie - the email us under the Canadian or North American server, while you're signing up under the European server.

Resolution:

Contact our Support Team and ask them to release the email that is potentially under a different country's server at the moment or you can contact sales@clio.com.

 

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