Introducing The Law Community, the online community just for Clio customers. Sign up now.

Error: Waiting for the Api.segment.io Message Appears When Installing Clio Launcher

Issue:

  • When installing Clio Launcher an error message appears referencing the api.segment.io

Environment:

  • Clio Manage
  • Clio Launcher

Solution:

The workaround for this is to open an incognito browser and install Clio Launcher through the incognito browser. For more information on opening an incognito or private browser please click here.

 

Was this article helpful?
This information is confusing or wrong
This isn't the information that I was looking for
I don't like this functionality