KCS - Xero Error Message: Invoice # must be unique

Issue:

  • Xero Sync Failure shows "Invoice # must be unique". 

Environment:

  • Clio Web App
  • Xero

Additional Information:

Most common reasons this occurs:

  1. Customer Voided an Invoice and recreated it before Xero was able to release the number. A simple edit on the Invoice (change anything and then change it back) in Clio will get Clio to try again on the next cycle.

  2. Interest accumulates on it’s own ‘hidden’ Bills in Clio, that appear in Xero as their own Invoices. They use up Invoice #’s, and some customers notice ‘gaps’ in the visible numbers in Clio, so make manual edits to ‘correct’ it.

  3. Customer has been manually renumbering Invoices in Clio to follow an unsupported scheme. Commonly done to make Invoice Numbers per Client (ie/ Repeats 1, 2, 3, etc for each Client)

Cause:

This error usually occurs whenever you try to sync an Invoice to Xero when that number is already in use. 

Resolution:

  1. Edit the Invoice number in Clio to be unique
  2. Wait for sync to re-run

 

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