Issue:
- Xero Sync Failure shows "Invoice # must be unique".
Environment:
- Clio Manage
- Xero
Additional Information:
Most common reasons this occurs:
-
An Invoice was voided and recreated before Xero was able to release the number. A simple edit on the Invoice (change anything and then change it back) in Clio will get Clio to try again on the next cycle.
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Interest accumulates on its own ‘hidden’ Bills in Clio and appear in Xero as their own Invoices. They use up Invoice #’s, and some customers notice ‘gaps’ in the visible numbers in Clio and make manual edits to ‘correct’ it.
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You may have been manually renumbering Invoices in Clio to follow an unsupported scheme. Commonly done to make Invoice Numbers per Client (ie/ Repeats 1, 2, 3, etc for each Client), resulting in duplicates.
Cause:
This error usually occurs whenever you try to sync an Invoice to Xero when that number is already in use.
Resolution:
- Edit the Invoice number in Clio to be unique
- Wait for sync to re-run