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NetDocuments Error: "Failed to Create the Link. You May Not Have Sufficient Permissions." When Creating NetDocuments Contact or Matter From Clio

Issue:

  • Not able to create a Contact or Matter in NetDocuments from Clio Documents sub-tab. Receiving error message to check permissions. -- "Failed to create the link. You may not have sufficient permissions."
  • Net docs 
  • NetDocuments Error
  • Workspace Permissions
  • Cabinet Permissions
  • User Permissions in NetDocuments

Environment:

  • Clio Manage
  • NetDocuments

Additional Information:

For further information, please see the below:

Cause:

  • Contacts and Matters in NetDocuments are a part of the Lookup table for the Profiles that were created for your Repository in NetDocuments. To create new values in the Lookup table, a user must have permission to create lookup table entries. To do this, each user must be a Full Repository Admin or the Group(s) assigned to the Cabinet must be allowed to create new records to the lookup table.
  • As a single NetDocuments account contains individual users with different permissions (similar to Clio), the permissions will have to be changed to allow each user to edit/create "Contacts" and "Matters" lookup tables within the chosen Workspace on NetDocuments.

Resolution:

Permissions for the user will need to be modified by an Admin of the NetDocuments account.

In NetDocuments as Admin:

Option 1 - Edit Group Permissions

This assumes the user receiving this error is a member of a Group assigned to the Workspace.

  1. From NetDocuments Home, click the arrow in the upper right beside your name
  2. Click Admin
  3. Click the "Navigation Menu" (Three horizontal lines)
  4. Click Users & Groups
  5. Click Groups
  6. Click the name of the Group you need to change
  7. Click Edit
  8. Turn on Members are allowed to upload lookup tables
  9. Click Save 

Option 2 - Edit User Permissions

  1. From NetDocuments Home, click the arrow in the upper right beside your name
  2. Click Admin
  3. Click the "Navigation Menu" (Three horizontal lines)
  4. Click Users & Groups
  5. Under Users, click the name of the user you need to change
  6. Click Edit
  7. Change the "Repository admin type" to Full
  8. Click Save

Once the settings have been changed in NetDocuments, the user must reauthorize Clio with their NetDocuments account for the new settings to be recognized. Follow with the steps below.

In NetDocuments as the User who has had permissions changed:

  1. From NetDocuments Home, click the arrow in the upper right beside your name
  2. Click Settings
  3. Click Manage App Access
  4. Click Revoke Access beside "Clio Manage"
  5. Click OK to close settings

In Clio the user must reauthorize with NetDocuments for the new settings to take effect:

NOTE: We do not recommend Unlinking and Relinking your NetDocuments account within Clio during this process. Doing so will cause all existing Matter links to be deleted from Clio.

  1. Log in as the user who has had permissions changed
  2. Click Settings
  3. Click Documents
  4. Click Document Sources
  5. Click Configure NetDocuments
  6. If you see a "Reauthorize Account" button, click it to reauthorize Clio with Netdocuments
    netdocumentsreauth1.png

If you do not see the "Reauthorize Account" button pictured above, please wait 1-2 hours and then check again. You may also see the error pictured below while using NetDocuments within Clio during this time. If you see this message you may also reauthorize your account with the link in the error.

netdocumentsreauth2.png

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