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Why Didn't I Receive the Password Reset Email?

Issue:

  • Requested a password reset link and have not yet received the email
  • Password reset email
  • Did not get the email to reset my password
  • Reset my password email 

Environment:

  • Clio Manage

Additional Information:

Use these steps if you still don't have the password reset email after checking your spam/junk folder.

Cause:

The email address that you're attempting to reset the password on does not match the email linked with your Clio account

Resolution:

  • Ensure you are using the exact email address that was used in the creation of the account. Note: This includes dots (e.g. john.doe@clio.com), special characters, and capitalization
  • Consider whether you may have signed up using a different email address (e.g., your personal email address)
  • If you are still unsure of the email that was used, another account user can check what email address was used by going to Manage Users (Managing User Email Addresses)
  • Check your spam or junk inbox
  • If using Rules to filter Emails inside your Inbox, check the Folder specific to the Rule.  
  • If you're using Outlook, login to your Office 365 online version of Outlook.  It could be that your Outlook Desktop version is not syncing with Office 365.
  • If using Outlook Desktop, check "Notifications" Folder

 

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