Issue:
- Bill does not sync to Xero with error message on the Xero setup page
- TaxType field is mandatory error
Environment:
- Clio Manage
- Xero
Additional Information:
n/a
Cause:
This may indicate that an expense on the bill is attempting to sync to an expense account, using the Xero Expense Account Code Mapping feature, which no longer exists.
Resolution:
To reset the "Xero account code" setting for the Expense category:
- Check expenses on the bill to see which Expense Categories might be in use
- Click Activities in the main menu
- Click Manage categories
- Click Expense categories
- Click Edit beside the expense category being used by expenses on the bill
- Check to see if there is anything selected for "Xero account code"
- If there is not, click the dropdown
- Check to see if there is a listing for "undefined". This indicates that the Expense Category is mapped to a expense account which has been deleted or archived
- Choose a different account code from the dropdown
- Click Save category
- Click Edit beside the expense category again
- Delete the "Xero account code" that is selected
- Click Save category
To resync a bill, in Clio make an edit to the Bill, and wait up to 30 minutes. If the Bill has not synced to Xero, contact Clio Support.