Issue:
- Syncing Contact / Calendars with your Office 365 account
- Integrating OneDrive with your personal Microsoft account
- Authentication issue when using more than one Microsoft account ( tier )
Environment:
- Clio Manage
- Office 365 Business
- Microsoft OneDrive Personal
Additional Information:
- Microsoft has different tiers for their various services. They are entirely separate from each other and require different credentials to access. These tiers are;
- Business (Used to log in to Office 365)
- Personal
- School
- Note that the Office 365 Contacts/Calendar sync is only possible with the Business Standard tier.
- The login for these tiers can have the same emails but different passwords or the same emails and passwords. In the latter case, Microsoft will ask you to choose which account you're trying to use as shown below.
- All these tiers provide similar features such as; Email, Skype, OneDrive, Word, etc
- For example, the OneDrive logged in with the Business tier is entirely separate from the OneDrive logged in with the Personal tier. Thus files uploaded to the Business will not show up in the Personal.
- For additional information about how Clio integrate with Office 365, please refer to this article.
Cause:
- At this time Clio is unable to differentiate the different tiers because they are all under the Microsoft umbrella.
Resolution:
- The Office 365 Contacts/Calendar sync is only possible with the Business Standard tier, as such you will need to use the Business Standard account credentials for both the Contacts/Calendar sync and OneDrive.
- To sync contacts/calendar
- Navigate to Settings
- Select Contact and Calendar Sync
- Click Set Up Sync next to Office 365 contacts and calendars
- Sign into Office 365
- If given the option to choose which tier, please select the Business Standard account
- Click Allow
- Click Sync next to the Clio calendar you wish to sync
- See this article for more information on which calendars you can sync.
- Select to Link to an existing Office 365 Calendar
- Select the appropriate Office 365 Calendar from the Calendar field
- Click to Sync Calendar
- To integrate with OneDrive
- Click on Settings
- Click on Documents
- Click on the Document Sources sub-tab
- Click on Configure Microsoft OneDrive
- Click Link Microsoft OneDrive Account
- Log into OneDrive if you are asked, using your Office365 email and password
- If questioned select the Business Standard account
- To sync contacts/calendar
It can take up to 24 hours for the initial Calendar/Contact and OneDrive sync to complete.