This article may be out of date!
Visit the New Knowledge Center

Invalid Clio Grow Signup Link

Issue:

  • Problem signing up for a Clio Grow account

Environment:

  • Clio Grow

Additional Information:

n/a

Cause:

The Clio Grow signup link may be invalid one of the following reasons:

  1. The link has expired. (Signup links are valid for 5 days)
  2. The link was already used.
  3. Another signup link has been generated more recently than that link.

Resolution:

There are different resolution steps for each of these possible reasons:

If the link has expired:

Contact Clio support and they will generate a new signup link for you. They can be reached by phone at 1-888-858-2546 or by email at grow.support@clio.com.

If the link was already used:

Contact Clio support and they will generate a new signup link for you. They can be reached by phone at 1-888-858-2546 or by email at grow.support@clio.com.

If another signup link has been generated:

Check your email. You should have received another signup link, which you can use to start up your Clio Grow account.

Was this article helpful?
This information is confusing or wrong
This isn't the information that I was looking for
I don't like this functionality