Issue:
- Why do I get "Currency isn't supported for this account" when processing a credit card payment using Secure Payment Link?
Environment:
- Clio Manage
Additional Information:
For further information on changing the default currency on your account or a bill, please see the following:
Cause:
For U.S. based firms, the country of the firm address is listed as Canada instead of the United States.
Resolution:
Change the country of the firm address to the United States.
- Navigate to Settings in the navigation bar
- Click on Account and Payment Info
- Update the Country in the Address fields
- Click Save New Information
Additionally, confirm the firm's default currency and the bill's currency are both set to USD.