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Integrating with QuickBooks Desktop 2019 Or Later

Issue:

  • QuickBooks Desktop error preventing import: "The date in the distribution line must be the same as the transaction header"
  • Does QuickBooks Desktop Pro 2019 / 2020 / 2021 Integrate with Clio?
  • When attempting to import a Clio QB IIF file into QuickBooks Desktop 2019 / 2020, errors occur that imply that the dates on activities need to match the date of the invoice.
  • Sync Quickbooks 2019
  • [ERROR] is not a valid IIF record type [15100]
  • QBD 2020

Environment:

  • Clio Manage

Additional Information:

  • More detailed instructions for importing IIF files into QuickBooks Desktop can be found here.
  • While the workaround option suggested here says "Not recommended", this import works in the same way as the IIF import did in previous versions of QuickBooks Desktop.

Back up your QuickBooks files before starting this process. If you do not perform the backup you will NOT be able to undo this action if you discover that you missed an item in the date range or included an incorrect transaction in your data. 

Cause:

An update to QuickBooks Desktop 2019 has changed the import process. This error is a result of the change.

Solution:

  1. Back up your Quickbooks files
  2. Open QuickBooks Desktop 2019 or 2020
  3. Click on File
  4. Hover over Utilities
  5. Hover over Import
  6. Click on IIF Files...
  7. Click on the Import it for me. I'll fix it later link (Under the Import without review (not recommended) text)
  8. Click on the Import IIF button
  9. Select your IIF file
  10. Click on the Open button
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