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Client Having Trouble Receiving Forms in Grow

Issue:

  • When sharing a form or Email, Client does not receive it
  • A client with Msn, Yahoo, or Hotmail email addresses do not receive emails

Environment:

  • Clio Grow
  • Lexicata

Additional Information:

Confirm that there is an email address associated with the contact. 

Cause:

Your email is not synced to your Clio Grow Account, meaning that emails sent from Grow are sent through our own email servers as opposed to your email.

Resolution

Sync your email to your account. To do this follow these steps:

  1. Click Settings
  2. Click Email & Calendar Sync
  3. Click Sync email
  4. Login to your email provider

If you are still experiencing Sync Authentication Errors we suggest looking at this article: 

Sync Authentication Errors in Clio Grow

 

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