Issue:
- "Password does not meet strong password requirements" error appears even when the New password field says Strong
Environment:
- Clio Manage
Additional Information:
n/a
Cause:
Password reset link is in the junk folder of the email provider (such as Outlook)
Resolution:
- Move the email with the password reset link from your junk/spam/deleted folder into your inbox
- Reopen the link
- Setup the new password