San Diego’s got 2020 vision. Get your pass to the Clio Cloud Conference, October 15-16, 2020, at Year End prices!

"Cannot Reset Password: Does Not Meet Strong Password Requirements" Error even when the Password says 'Strong'

Issue:

  • "Password does not meet strong password requirements" error appears even when the New password field says Strong

Environment:

  • Clio Manage

Additional Information:

n/a

Cause:

Password reset link is in the junk folder of the email provider (such as Outlook)

Resolution:

  1. Move the email with the password reset link from your junk/spam/deleted folder into your inbox
  2. Reopen the link
  3. Setup the new password

 

Was this article helpful?
This information is confusing or wrong
This isn't the information that I was looking for
I don't like this functionality