Issue:
- QuickBooks Online Error Code (620): TxnID cannot be linked
Environment:
- Clio Manage
- QuickBooks Online
Additional Information:
- For a full list of Quickbooks Online Error Codes that you might encounter, click here.
- For more information on how you can find Quickbooks Online errors in your account, click here.
Cause:
- An invoice / sales receipt record with this number already exists in QuickBooks.
- Additionally, this invoice / sales receipt in QuickBooks exists under a different customer than the customer for the Bill in Clio is mapped to in QuickBooks.
- This almost always means that the existing invoice / sales receipt record in QuickBooks is a totally different/unrelated record.
Resolution:
- Revert any changes made to the Matter Client in Clio, if it's been modified since the Bill was synced over to QuickBooks Online.
- Change the Invoice ID to be unique, and re-sync.
- If that doesn't work, you may need to re-generate the Bill to force the re-sync (with a new Transaction ID.)