Introducing The Law Community, the online community just for Clio customers. Sign up now.

Why is US showing on the Bill even though the Client is inside the United States?

Issue:

  • US is showing in the address field on a Bill even though the client and Firm are located in the United States. 

Environment:

  • Clio Manage

Additional Information:

n/a

Cause:

Incorrect Country chosen 

Resolution:

  1. Go to the Contact
  2. Click Edit
  3. Scroll down to Address and change Country field from "US" to the "United States"
  4. Click Save Contact

The US should now be removed from the address on any Bills. 

 

Was this article helpful?
This information is confusing or wrong
This isn't the information that I was looking for
I don't like this functionality