Issue:
- Not getting password reset email
- Email change email not being delivered
- Invited user didn't get their email
- Clio Connect user never got an email
- System emails not being delivered
Environment:
- Clio Manage
- Clio Grow
- Your Email Account
Additional Information:
n/a
Cause:
There are a number of possible causes for this:
Resolution:
- Type in the word "clio" into the search bar of your email inbox and press Enter (sometimes due to filters, emails may end up in folders other than Spam/Trash) - notice if the reset password email is showing now.
- Verify that there are no pending user invites that were sent by an Admin in your account. If there are, please delete pending invites if you already have an active login with Clio.
- Send the reset password, email through an incognito/private window
- Verify that the destination email address is correct (***especially if there are capitalized vs small letters in the original email***)
- Verify that you are checking the correct email inbox
- Try waiting for up to 10 minutes (email deliverability can sometimes be delayed by factors outside of Clio's control)
- Try checking your Spam filter:
- Verify that you are not using any automated email rules that may be redirecting the email
- Try searching for the email in your email program (for a list of emails, it may have come from, see here)
- Try Whitelisting Clio Emails, then resending the original email (see here)
- Verify that your email domain is properly configured using MX Lookup (see here)
- If receiving an email is time-critical, try sending it to another email address owned by the intended recipient
- Contact Clio Support (see here)