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Cannot Update Clio Connect Email of a Contact

Issue:

  • After replacing the email address of a contact and saving it, the email address reverts back to the original one

Environment:

  • Clio Manage

Additional Information:

n/a

Cause:

There is already an existing full Firm User account with the email address you are trying to replace the Clio Connect contact's email with.  

 If the firm account and and the Clio Connect account were initially created under the same email, then you would have been able to save the email without adding a +1 to it.  

Resolution:

  1. Create an alias email with +1 as part of the email address.
  2. Replace the Clio Connect contact's email with the +1 email alias
  3. The Save the contact

 

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