Passes to the Clio Cloud Conference are $99. Invest in your firm's success today.

"Your email needs to be reconnected to continue sending messages from Grow. Click here to visit settings and reconnect." Error Keeps Showing Up After Reconnecting Email with Grow

Issue:

  • Cannot reconnect to email through Clio Grow
  • Email sync keeps failing
  • Email sync disconnects often

Environment:

  • Clio Grow

Additional Information:

Cause:

Email sync has become disconnected.

Resolution 

If you have already attempted to disconnect and reconnect your email sync, please reach out to our Support Team and reference this article.

If you have not yet attempted to resync your email please follow the steps below:

  1. Click the link that says Click here to visit settings and reconnect
  2. Click Sync Email
  3. Choose your email account
  4. Click Allow
  5. Refresh your page
Was this article helpful?
This information is confusing or wrong
This isn't the information that I was looking for
I don't like this functionality