The Clio Cloud Conference is happening October 26-29. Save your spot.

Why is There a Negative Trust Balance Showing on the Bill?

Issue:

  • Invoice showing negative Trust balance

Environment:

  • Clio Manage

Cause:

Incorrect contact level trust balance.

Resolution:

Check and reconcile trust transactions under the client by clicking the Transactions tab and choosing the Trust account.

 

Was this article helpful?
This information is confusing or wrong
This isn't the information that I was looking for
I don't like this functionality