Virtual meetup: How to Win and Retain Clients by Automating Communication. Register now.

Issue: Payment Failed to Process the Region You Are in Is Not Currently Supported

Issue:

  • Payment failed error message when attempting to process payment in Clio Manage

Environment:

  • Clio Manage
  • Clio Payments

Cause:

This issue is caused by the allowed regions that are set up in LawPay for processing payments through Clio Payments.

Resolution:

Please call LawPay Support to change the allowed regions and add the region that is being denied. Once the region has been added in your LawPay account you will be able to process the credit card payment successfully. 

LawPay Support line: 800-459-5798 

LawPay email:  support@lawpay.com

 

Was this article helpful?
This information is confusing or wrong
This isn't the information that I was looking for
I don't like this functionality