This article may be out of date!
Visit the New Knowledge Center

Error Message: "Device Isn't Compatible with this Version" When Downloading Clio For Clients from the App Store / Play Store

Issue:

  • Unable to download Clio For Clients App from the Google Play Store
  • Can't get the CFC or C4C from the iOS store
  • What OS version of Android/iOS do I need to use Clio For Clients?

Environment:

  • Clio For Clients, Android
  • Clio For Clients, iOS

Additional Information:

  • n/a

Cause

Your mobile device isn't compatible with Clio For Clients. You must have iOS 10.3 / Android OS 8.0 or higher.

Resolution:

You can access Clio for Clients via a web browser by navigating to clients.clio.com and entering the email address associated with your Clio for Clients notification email.

 

Was this article helpful?
This information is confusing or wrong
This isn't the information that I was looking for
I don't like this functionality