Virtual meetup: How to Win and Retain Clients by Automating Communication. Register now.

Why Can't I See Any Activities on the Activities Page?

Question:

  • Why can't I find any Activities on the Activities Page?
  • Where did all my Activities go?
  • I don't see my Activities on the Activities Page.

Environment:

  • Clio Manage

Additional Information:

  • n/a

Cause:

  • This issue could be caused by active filters or an incorrect Date Range

Answer:

  1. Click the Filters button
  2. Click Clear Filters
  3. Expand the Date Range to ensure it is not set to Today
  4. Check to ensure that All is selected and not just Time or Expenses
  5. If you still cannot find your Activities Contact Support
Was this article helpful?
This information is confusing or wrong
This isn't the information that I was looking for
I don't like this functionality