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"Sorry we couldn't find the page you're looking for. Please double check that the address is correct, or return to Clio." Error When Clicking on the Activate Account Button in an Email

Issue:

  • Getting "Sorry we couldn't find the page you're looking for." error when trying to activate my account

Environment:

  • Clio Manage

Additional Information:

  • n/a

Cause:

The account is already active.

Resolution:

  1. Try logging into app.clio.com
  2. If you do not remember or do not have a password, you can click on the I forgot my password link on the next page after putting in your email address
  3. If you are still unable to get into your account, please contact us.
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