KCS - Unable to Save Changes to Account Information

Issue:

  • Updates to Firm Information are not saved when I click on "Save New Information"
  • Why can't I edit my firm address in Settings? 

Environment:

  • Clio Web App

Additional Information:

How to Edit User Permissions

Cause:

Only account administrators are able to modify account information.

Resolution:

A user with Administrator Permission will need to make the changes, or update your Permissions to make you an Administrator 

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